STL is the standard file type used by most additive manufacturing systems. STL is a triangulated representation of a 3D CAD model

The triangulation of a surface will cause faceting of the 3D model. The parameters used for outputting a STL will affect how much faceting occurs.


 You cannot build the model smoother than the STL file, so if the STL is coarse and faceted, that is what you can expect in the final model. When exporting to STL in your CAD package, you may see parameters for chord height, deviation, angle tolerance, or something similar. These are the parameters that affect the faceting of the STL. You don’t necessarily want to design too small. The more detailed the STL, the larger the file size, which will affect processing time in Insight, 3D printing software, as well as build time.

Preparing your files

The following step-by-step instructions for converting CAD files to STL came from each CAD software company’s website. If your CAD software is not listed below or if you require additional assistance, please contact your CAD software technical support for information about exporting to an STL.


  1. Select STL command
  2. Maximum Seg to 0.015mm
  3. Select the model, then select Yes
  4. Select Export, then type file name, then OK

Catia can import almost any design-file format, but only those that include solid data (IGES, STEP, Parasolid, etc.)

STL files can be saved – with a special add-on module. Catia V5 is capable of creating STL files from parts (CatiaPART files), but not from assemblies (CatiaPRODUCT files) or geometrical representations (car files). Therefore, source files, including those saved in a neutral format (STEP or IGES, for example), must be saved as parts. If the source design was saved as an assembly, it is imported to Catia as a product.

To create an STL file from it, you must first convert it to a multi-bodied part. The procedure described below is one of several methods for doing this.

Phase 1: Saving a model design in STL format
Opening and Preparing the Source File:

  1. From the File menu, select Open, and open the source file. If the source design was saved as an assembly, it is imported as a CatiaPRODUCT model.
  2. Save the product file
  3. From the File menu, select New then Part, and give it the name of one of the components.
  4. In the product window, select this component, and copy it (with the Edit menu or the right-click pop-up menu).
  5. In the part window, paste the component
  6. Repeat steps and until you have copied all of the components and pasted them as individual parts. Figure on the right shows the result of pasting the components of the product into individual part files
  7. From the File menu, select New then Part, and give it a name suitable for the combined model
  8. Copy each of the individual components (parts) from the working files and paste them into the new (combined) model file Since the geometries of all of the parts are retained, they should be aligned correctly in the combined part. The new part is now ready to be exported as an STL file.

Phase 2: Re-aligning parts (if necessary)
Occasionally, because of the way the original assembly was designed, some of the components may not align correctly in the combined part. If so, you must align them, using the Constraints feature, from the Insert menu. Before saving the file, it is advisable to review the settings that determine the accuracy of the model – and the size of the file. To see these parameters:

  1. From the Tools menu, select Options
  2. In the Options dialog box, display the Performance tab
  3. Under the General category (on the left), select Display
  4. Pay attention to the 3D Accuracy settings

Fixed – The lower the setting, the finer the details of the model in the STL file. A very small setting results in a very large STL file. Curves’ accuracy ratio – The higher the setting, the smoother the surface will be, when dealing with complex geometries, especially if surfaces contain sudden small changes with small radii (like the bumps on a golf ball).

Phase 3: Saving the Part as an STL File
After preparing the part, as described above, proceed as follows:

  1. From the File menu, select Save As
  2. In the Save As dialog box, select .stl from the Save As Type pull-down list
  3. Click Save

Since Catia5 supports non-continuous model designs, importing geometry into a part by copying and pasting is not problematic.